guam plaza hotel best guaranteed
  • fb icon
  • instagram icon
  • twitter icon
  • youtube icon

Café at Rootz - Menu

Warning message

Mean Menu style requires jQuery library version 1.7 or higher, but you have opted to provide your own library. Please ensure you have the proper version of jQuery included. (note: this is not an error)

CHECK OUT OUR POPULAR MENU...




Graphical Map


The inline option preserves bound JavaScript events and changes, and it puts the content back where it came from when it is closed.